Opening files
You can open FileMaker Pro files located on your computer. You can open single files or multiple files at the same time.
There are other methods of opening files and other types of files that you can open. You can:
  •
  •
Open FileMaker Pro files that may be available as shared databases on your network. For more information, see Working with shared files as a client. If you have marked any files as favorites in the Remote Hosts dialog box, the FileMaker Quick Start Screen gives you quick access to them.
  •
Convert files created with an earlier version of FileMaker Pro into the current FileMaker Pro format. For more information, see Converting files from FileMaker Pro 6 and earlier.
  •
Convert compatible files created in other applications—such as Microsoft Excel files, Bento 2 (or a later supported version) files, or tab-delimited text files files—to FileMaker Pro format.
To open a file if FileMaker Pro is already running:
1.
Choose File menu > Open.
2.
3.
For more information, see Opening protected files.
To open a file if FileMaker Pro isn’t running:
  •
Drag the file onto the FileMaker Pro application icon.
  •
Double-click the FileMaker Pro file.
Tip  You can enable an option in Preferences to display recently opened filenames. To enable this option, choose Edit menu (Windows) or FileMaker Pro menu (Mac OS) > Preferences and select Show recently opened files. If the file is one you have recently opened, you can choose it from File menu > Open Recent.
To open multiple files at the same time:
1.
 
From within FileMaker Pro
Choose File menu > Open, and select all the files that you want to open in the Open File of FileMaker Quick Start Screen:
  •
To select multiple files, hold down Control (Windows) or Command (Mac OS), and click each file.
  •
To select a range of adjacent files, click the first file, then Shift-click the last file in the range.
Then click Open or OK.
In a Windows Explorer window or
a Mac OS Finder window
Select the files you want to open, then drag them onto the FileMaker Pro application icon.
Drag the folder onto the FileMaker Pro application icon.
Note  FileMaker Pro only opens files located directly in the folder. Any files that exist in any enclosed folders are not opened.
2.
The Open Multiple Files dialog box only appears if one or more of the files you open are in a format that FileMaker Pro can convert, such as Microsoft Excel, tab-delimited text, or FileMaker Pro 6. You can choose to do one of the following in the Open Multiple Files dialog box:
  •
Open current FileMaker Pro files only. Do not convert any files.
  •
Open current FileMaker Pro files and convert any compatible files into FileMaker Pro files. FileMaker Pro saves the converted files into a folder you specify, automatically naming each file based on the name of the source file.
Notes
  •
  •
If a file opens with a default password, you can specify a different password by pressing the Shift key (Windows) or the Option key (Mac OS) when opening the file.
  •
You can open a FileMaker Pro for Windows file on the Mac OS, and vice versa. If you intend to move files across platforms, it’s best to include the .fp7 extension in the filename. If you add or remove filename extensions, you must re-specify the data source (formerly known as file references) for related files and files with external scripts.
  •
If you have FileMaker Pro Advanced, you can:
  •
  •
Related topics 
Opening shared files as a client
Opening files troubleshooting
Closing windows and files
Closing files troubleshooting