Pour Windows et Mac

Caractéristiques techniques

FileMaker Server 18

Contenu

FileMaker Server 18 est uniquement disponible sous forme de téléchargement. Cette version contient le logiciel correspondant au produit et un lien vers un certificat de licence électronique contenant la clé de licence requise pour l'installation. La documentation produit est disponible en ligne.


Langues prises en charge : allemand, anglais, espagnol, français, italien et japonais.

Compatibilité

FileMaker Server 18 prend en charge les clients suivants :

  • FileMaker Pro 16
  • FileMaker Pro 18, 17 et 16 Advanced
  • FileMaker Go 18, 17 et 16
  • Apps créées à l'aide du SDK 18, 17 et 16 pour apps iOS
  • FileMaker WebDirect

Les dernières mises à jour de sécurité doivent être appliquées aux clients ci-dessus avant toute connexion à FileMaker Server 18. Il se peut que certaines fonctions ne soient pas rétrocompatibles. En savoir plus

Configuration système requise

Remarque : macOS Sierra 10.12 n'est plus pris en charge. Mettez à jour votre système d'exploitation avant de passer à FileMaker Server 18.

Systèmes d'exploitation certifiés*
Windows Server 2016 Datacenter Edition et Standard Edition (avec Expérience utilisateur)
Windows Server 2012 R2 Standard Edition avec mise à jour (voir Microsoft KB 2919355)
macOS Mojave 10.14
macOS High Sierra 10.13

*La version indiquée constitue le minimum requis. Il se peut que FileMaker Server fonctionne également avec des versions ultérieures des systèmes d'exploitation certifiés par FileMaker, Inc. Les systèmes d'exploitation non répertoriés dans le tableau ci-dessus peuvent fonctionner mais ils n'ont pas été testés et ne sont pas pris en charge.

Configuration matérielle requise

Nous vous recommandons d'utiliser un ordinateur dédié pour FileMaker Server.

Configuration minimale requise
Processeur : bicœur
Mémoire RAM : 8 Go
Disque dur : 100 Go ou plus, selon la taille des fichiers ; 50 Go d'espace disque disponible minimum. SSD (Solid State Drive) recommandé.
Lecteur du système d'exploitation

FileMaker Server utilise le lecteur du système d'exploitation pour permettre le stockage temporaire du téléchargement progressif, du chargement et du téléchargement d'apps, de fichiers journaux et le stockage du cache utilisé par les composants tels que le serveur Web.

Afin de bénéficier de performances optimales, FileMaker Server nécessite 100 Go d'espace de stockage disponible ou plus, même si les apps sont hébergées ou sauvegardées sur un autre disque. L'administrateur du serveur doit surveiller le lecteur du système d'exploitation de façon à s'assurer qu'un stockage suffisant est disponible.

FileMaker WebDirect
Langues prises en charge

Allemand, anglais, chinois simplifié, coréen, espagnol, français, italien, japonais, néerlandais, portugais (Brésil) et suédois.

Navigateurs Web pris en charge

FileMaker WebDirect est accessible à partir d'un navigateur Web. Navigateurs Web pris en charge :

Navigateurs pour ordinateurs de bureau Navigateurs mobiles
Safari 12.x ou version ultérieure Safari Mobile sous iOS 12.x ou version ultérieure
Chrome 73 ou version ultérieure Chrome 73 ou version ultérieure sous Android 7.x ou version ultérieure
Internet Explorer 11.x
Microsoft Edge 44
Configuration matérielle requise pour les appareils mobiles*
Plateforme Appareils pris en charge
iPad iPad Pro (12,9, 11 et 10,5 pouces)
iPad (9,7 pouces)
iPad Air
iPad mini 5
iPad mini 4
iPhone iPhone XS
iPhone XS Max
iPhone XR
iPhone X
iPhone 8
iPhone 8 Plus
iPhone 7
iPhone 7 Plus
Android Mémoire : 3 Go de RAM minimum
Processeur : processeur quadricœur 2,1 GHz ou supérieur
Taille de l'écran : 5 pouces minimum

*FileMaker WebDirect peut fonctionner sur d'autres appareils non répertoriés dans le tableau ci-dessus, mais ces appareils n'ont pas été testés et ne sont pas pris en charge.

Accessoires matériels mobiles FileMaker WebDirect
  • Smart Keyboard pour iPad Pro
  • Apple Pencil pour iPad Pro
Configuration du réseau mobile

Une connexion réseau avec une force du signal et une connectivité constantes est requise.

Réseaux mobiles pris en charge
Wi-Fi LTE 4G
Configurations matérielles recommandées

Une connexion réseau avec une force du signal et une connectivité constantes est requise.

*Les connexions peuvent être limitées par le matériel, la conception des apps, le système d'exploitation ou le contrat de licence.

Pour en savoir plus

Pour plus d'informations sur FileMaker WebDirect, consultez le Guide de FileMaker WebDirect.

Capacités

Le tableau ci-dessous répertorie le nombre maximal théorique de connexions simultanées tel que testé pour FileMaker Server 18. Ces limites reflètent la configuration de test et ne constituent pas une garantie de performance.


FileMaker Server peut héberger jusqu’à 125 fichiers FileMaker Pro Advanced. 

Client Nombre testé* Nombre maximum autorisé*
FileMaker Pro Advanced 500 2000
FileMaker Go 500 500
FileMaker WebDirect 500 500
Publication Web personnalisée** 500 2000
FileMaker Data API 500 500
ODBC/JDBC 50 Illimité

*Les connexions sont limitées uniquement par le matériel, la conception des apps, le nombre d'utilisateurs actifs, le système d'exploitation ou le contrat de licence.

**La Publication Web personnalisée dépend des événements de requêtes simultanés et non des connexions persistantes.

Licence Utilisateur

Les licences Utilisateur permettent aux clients FileMaker Pro Advanced, FileMaker Go et FileMaker WebDirect de se connecter à FileMaker Server. Elles peuvent être achetées via l'Admin Console de FileMaker Server ou le FileMaker Store. Apprenez-en davantage sur les licences Utilisateur FileMaker.

Configuration requise pour une utilisation des clients en réseau
FileMaker ProAdvanced FileMaker Pro Advanced requiert une licence logicielle.
Sources de données SQL externes Consultez la liste des pilotes pris en charge. (EN)
Configuration supplémentaire requise
Technologie Configuration requise
Java FileMaker Server 18 est actuellement certifié pour fonctionner avec JRE 1.8.0_201. Consultez l'historique des versions de Java et FileMaker Server.
PHP FileMaker Server 18 installe ce dont vous avez besoin pour utiliser la fonctionnalité Publication Web personnalisée avec PHP, notamment le moteur PHP, l'API FileMaker pour PHP et la documentation liée. Utilisez la toute dernière version de PHP certifiée par FileMaker, Inc.

Les utilisateurs de Windows doivent utiliser PHP 7.1.19.
Les utilisateurs de macOS Mojave 10.14 doivent utiliser PHP 7.1.19.
Les utilisateurs de macOS High Sierra 10.13 doivent utiliser PHP 7.1.16.
Admin Console L'Admin Console de FileMaker Server est accessible via un navigateur Web à partir d'un ordinateur qui dispose d'un accès réseau à FileMaker Server 18. Navigateurs Web pris en charge :
  • Safari 12.x
  • Internet Explorer 11.x
  • Chrome 73 ou version ultérieure
  • Microsoft Edge 44
Les versions indiquées constituent la configuration minimale requise. L'Admin Console de FileMaker Server peut fonctionner avec des versions de navigateur plus récentes certifiées par FileMaker, Inc.
Sources de données ESS prises en charge Microsoft SQL Server 2017
Microsoft SQL Server 2016
Microsoft SQL Server 2014
MySQL Community Server 5.7.21
Oracle Database 11g Release 2
Oracle Database 12c Release 1
Oracle Database 12c Release 2
IBM Db2 for i.7.3 (via l'adaptateur de source de données SQL externe Actual)
IBM Db2 Version 11.1 (via l'adaptateur de source de données SQL externe Actual)
PostgreSQL 9.6.12 (via l'adaptateur de source de données SQL externe Actual)
Sécurité Prise en charge du cryptage AES-256 des données à l'arrêt lorsque les fichiers de base de données sont cryptés par la fonctionnalité de cryptage de FileMaker.

Le partage, la lecture et l'écriture de fichiers cryptés au format AES 256 bits sont pris en charge par l'ensemble des produits de la plateforme FileMaker 18.

Prise en charge des fournisseurs de certificats SSL d'autorités de certification tierces. Consultez la liste des certificats SSL pris en charge.
Technologies déconseillées et supprimées

FileMaker, Inc. investit sans cesse dans les dernières technologies afin de continuer à améliorer la plateforme FileMaker. Par conséquent, certains systèmes d'exploitation et fonctions sont déconseillés et seront supprimés dans les prochaines versions du logiciel FileMaker. Consultez la liste des technologies déconseillées.