ファイルの修復
ファイルが損傷していることが示された場合は、まず最適化コピーの保存を試みます。これはすべてのデータをコピーし、データベースのツリー構造を再構築します(最適化コピーの保存を参照してください)。ファイルを開けない場合でも、[詳細修復オプション] ダイアログボックス(以下を参照)を使用して最適化コピーを作成できます。ファイルの損傷が激しく、開いたり使用したりできない場合、[修復] コマンドを使用して FileMaker Pro で出来る限り多くのデータを復元し、新しい修復されたファイルを作成できます。
メモ  FileMaker Pro Advanced: Runtime アプリケーションでは、詳細なファイルの修復機能はサポートされていません。
損傷したファイルを修復するには、次の操作を行います。
1.
[ファイル] メニューから [修復...] を選択します。
2.
修復するファイルを選択して、[選択] をクリックします。
[修復後のファイル名] ダイアログボックスが表示されます。ファイル名(Windows)または 名前:(OS X)に対し、元のファイル(損傷した)ファイル名の後ろに(修復)が追加されて表示されます。
3.
4.
デフォルトのファイルの修復設定(最適な結果を得るために推奨)を使用するには、[詳細オプションの使用] が選択解除されていることを確認してから、次の手順に進みます。
修復の設定を変更するには、[詳細オプションの使用] を選択するか、[指定...] をクリックし、オプションを設定して、[OK] をクリックします。(詳細修復オプションについては、詳細なファイル修復オプションの設定を参照してください。)
5.
[保存] をクリックします。
6.
暗号化パスワードが分からない場合は、データベース管理者に問い合わせてください。
修復の進行状況が表示されます。操作が終了すると、修復したファイルのステータスが表示されます。詳細については、修復結果を参照してください。
7.
修復プロセスのログを表示するには、[ログファイルを開く...] をクリックします。
Recover.log ファイルが、タブ区切り形式で別のウインドウで開かれます。列の左から右に、修復が行われた日付、時刻、時間帯、ファイル名、エラー数、修復イベントの説明が示されます。さらに詳しく検査するため、このファイルを保存したり印刷したりできます。ウインドウを閉じます。
既存の Recover.log ファイル情報には最近のデータが追加されるため、最新のファイル修復の結果を参照するにはファイルの最後までスクロールする必要があります。
詳細については、https://filemaker-jp.custhelp.com から利用可能な、FileMaker ナレッジベースを検索してください。また、表示されたメッセージに含まれるキーワードも使用して検索してください。
メモ  これらの手順は、FileMaker Pro 12 形式のファイルに対してのみ適用されます。異なる FileMaker Pro 形式で作成されたファイルを修復するためにこれらのステップを使用するには、ファイルを FileMaker Pro 12 形式に変換する必要があります。ファイルの損傷が激しく変換できない場合、該当するバージョンのアプリケーションでファイルを修復します。FileMaker Pro 11以前のデータベースの変換を参照してください。
修復結果
ファイルが修復されると、ステータス情報が表示されます。表示される情報は、修復操作の結果および使用したオプションによって異なります。次の表は、修復可能な各データベースコンポーネントで表示される可能性のあるすべての結果を示します。(詳細については、詳細なファイル修復オプションの設定を参照してください。)
 
 •
「<nnn>」ブロックがスキャンおよび再構築され、「<nnn>」の無効なデータブロックがドロップされました。
 •
フィールドおよびテーブルがスキャンされました。「<nnn>」個の見つからないフィールドが追加されました。
 •
スキャンされました。 「<nnn>」 項目が変更されました。
多くの場合、正常に修復されたデータベースは元のデータベースよりも大きくなります。これは、データベースが修復されるときに新しいディスクブロックが割り当てられるためです。たとえば、フィールドごとに、またレコードごとに索引を作成していくと、データの配置が元のファイルとは異なる(または大きくなる)可能性があります。
ファイルを修復した後、修復したファイルから最新のデータを元のファイルのバックアップコピーにコピーします。修復したファイルではなく、そのファイルを使用するのがもっとも安全な方法です。
メモ  また、新たに修復したデータベースを開く場合は、正常に終了することができたデータベースを開く場合よりも時間がかかります。修復したデータベースを初めて開く場合にのみ発生します。
関連項目 
ファイルの修復のトラブルシューティング